# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*=(.*)=.*|(.*)=.*"
test_str = ("\"I have candy='4' and ice cream = 'vanilla'\"\n"
"I have candy='4' and ice cream = 'vanilla' and house='big'\n"
"Regex is fun\n"
"Regex is beauty =\n"
"Regex is awesome = test test test\n")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.