const regex = /.*=(.*)=.*|(.*)=.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*=(.*)=.*|(.*)=.*', 'g')
const str = `"I have candy='4' and ice cream = 'vanilla'"
I have candy='4' and ice cream = 'vanilla' and house='big'
Regex is fun
Regex is beauty =
Regex is awesome = test test test
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);