package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{2}(\/|-)\d{2}(\/|-)\d{2,4})`)
var str = `MM/DD/YY = 07/13/20
MM/DD/YYYY = 07/13/2020
MM-DD-YY = 07-13-20
MM-DD-YYYY = 07-13-2020`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}