re = /(\d{2}(\/|-)\d{2}(\/|-)\d{2,4})/m
str = 'MM/DD/YY = 07/13/20
MM/DD/YYYY = 07/13/2020
MM-DD-YY = 07-13-20
MM-DD-YYYY = 07-13-2020'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end