// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{2}(\/|-)\d{2}(\/|-)\d{2,4})").unwrap();
let string = "MM/DD/YY = 07/13/20
MM/DD/YYYY = 07/13/2020
MM-DD-YY = 07-13-20
MM-DD-YYYY = 07-13-2020";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}