$re = '/(\d{2}(\/|-)\d{2}(\/|-)\d{2,4})/m';
$str = 'MM/DD/YY = 07/13/20
MM/DD/YYYY = 07/13/2020
MM-DD-YY = 07-13-20
MM-DD-YYYY = 07-13-2020';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);