const regex = /(\d{2}(\/|-)\d{2}(\/|-)\d{2,4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}(\\\/|-)\\d{2}(\\\/|-)\\d{2,4})', 'gm')
const str = `MM/DD/YY = 07/13/20
MM/DD/YYYY = 07/13/2020
MM-DD-YY = 07-13-20
MM-DD-YYYY = 07-13-2020`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}