#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((\.\d+)|(0+((e|E)\d+)?)|(0+\.\d*((e|E)-\d+)?)|((1|1\.0*)((e|E)-\d+)?)|(1\.\d+((e|E)-[1-9]\d*)))(\s+|,\s*)){3}((\.\d+)|(0+((e|E)\d+)?)|(0+\.\d*((e|E)-\d+)?)|((1|1\.0*)((e|E)-\d+)?)|(1\.\d+((e|E)-[1-9]\d*)))$(" & @CRLF & _
"# just a way to comment" & @CRLF & _
"# The ^$ anchors are there because xml always assumes them." & @CRLF & _
"# They are required here for proper testing." & @CRLF & _
")*"
Local $sString = "1 1 1 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")