import Foundation
let pattern = ##"""
^(((\.\d+)|(0+((e|E)\d+)?)|(0+\.\d*((e|E)-\d+)?)|((1|1\.0*)((e|E)-\d+)?)|(1\.\d+((e|E)-[1-9]\d*)))(\s+|,\s*)){3}((\.\d+)|(0+((e|E)\d+)?)|(0+\.\d*((e|E)-\d+)?)|((1|1\.0*)((e|E)-\d+)?)|(1\.\d+((e|E)-[1-9]\d*)))$(
# just a way to comment
# The ^$ anchors are there because xml always assumes them.
# They are required here for proper testing.
)*
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1 1 1 1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}