const regex = /^(((\.\d+)|(0+((e|E)\d+)?)|(0+\.\d*((e|E)-\d+)?)|((1|1\.0*)((e|E)-\d+)?)|(1\.\d+((e|E)-[1-9]\d*)))(\s+|,\s*)){3}((\.\d+)|(0+((e|E)\d+)?)|(0+\.\d*((e|E)-\d+)?)|((1|1\.0*)((e|E)-\d+)?)|(1\.\d+((e|E)-[1-9]\d*)))$(
# just a way to comment
# The ^$ anchors are there because xml always assumes them.
# They are required here for proper testing.
)*/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((\\.\\d+)|(0+((e|E)\\d+)?)|(0+\\.\\d*((e|E)-\\d+)?)|((1|1\\.0*)((e|E)-\\d+)?)|(1\\.\\d+((e|E)-[1-9]\\d*)))(\\s+|,\\s*)){3}((\\.\\d+)|(0+((e|E)\\d+)?)|(0+\\.\\d*((e|E)-\\d+)?)|((1|1\\.0*)((e|E)-\\d+)?)|(1\\.\\d+((e|E)-[1-9]\\d*)))$(
# just a way to comment
# The ^$ anchors are there because xml always assumes them.
# They are required here for proper testing.
)*', 'm')
const str = `1 1 1 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}