import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+?((\\.\\d+([eE]-\\d+)?)|((0+(\\.0*)?|\\.0+)([eE]\\+?\\d+)?)|(0+\\.\\d*([eE]-\\d+)?)|((1|1\\.0*)([eE]-\\d+)?)|(\\d(\\.\\d*)?([eE]-[1-9]\\d*)))\\s+){3}(\\+?((\\.\\d+([eE]-\\d+)?)|((0+(\\.0*)?|\\.0+)([eE]\\+?\\d+)?)|(0+\\.\\d*([eE]-\\d+)?)|((1|1\\.0*)([eE]-\\d+)?)|(\\d(\\.\\d*)?([eE]-[1-9]\\d*))))$(\n"
+ "# just a way to comment\n"
+ "# The ^$ anchors are there because xml always assumes them.\n"
+ "# They are required here for proper testing.\n"
+ ")*";
final String string = "0.0e10 .0e+10 .0 0e-10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}