use strict;
my $str = '0.0e10 .0e+10 .0 0e-10';
my $regex = qr/^(\+?((\.\d+([eE]-\d+)?)|((0+(\.0*)?|\.0+)([eE]\+?\d+)?)|(0+\.\d*([eE]-\d+)?)|((1|1\.0*)([eE]-\d+)?)|(\d(\.\d*)?([eE]-[1-9]\d*)))\s+){3}(\+?((\.\d+([eE]-\d+)?)|((0+(\.0*)?|\.0+)([eE]\+?\d+)?)|(0+\.\d*([eE]-\d+)?)|((1|1\.0*)([eE]-\d+)?)|(\d(\.\d*)?([eE]-[1-9]\d*))))$(
# just a way to comment
# The ^$ anchors are there because xml always assumes them.
# They are required here for proper testing.
)*/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}