# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"^(\+?((\.\d+([eE]-\d+)?)|((0+(\.0*)?|\.0+)([eE]\+?\d+)?)|(0+\.\d*([eE]-\d+)?)|((1|1\.0*)([eE]-\d+)?)|(\d(\.\d*)?([eE]-[1-9]\d*)))\s+){3}(\+?((\.\d+([eE]-\d+)?)|((0+(\.0*)?|\.0+)([eE]\+?\d+)?)|(0+\.\d*([eE]-\d+)?)|((1|1\.0*)([eE]-\d+)?)|(\d(\.\d*)?([eE]-[1-9]\d*))))$(\n"
r"# just a way to comment\n"
r"# The ^$ anchors are there because xml always assumes them.\n"
r"# They are required here for proper testing.\n"
r")*")
test_str = "0.0e10 .0e+10 .0 0e-10"
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.