$re = '/^(\+?((\.\d+([eE]-\d+)?)|((0+(\.0*)?|\.0+)([eE]\+?\d+)?)|(0+\.\d*([eE]-\d+)?)|((1|1\.0*)([eE]-\d+)?)|(\d(\.\d*)?([eE]-[1-9]\d*)))\s+){3}(\+?((\.\d+([eE]-\d+)?)|((0+(\.0*)?|\.0+)([eE]\+?\d+)?)|(0+\.\d*([eE]-\d+)?)|((1|1\.0*)([eE]-\d+)?)|(\d(\.\d*)?([eE]-[1-9]\d*))))$(
# just a way to comment
# The ^$ anchors are there because xml always assumes them.
# They are required here for proper testing.
)*/m';
$str = '0.0e10 .0e+10 .0 0e-10';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);