const regex = /^(\+?((\.\d+([eE]-\d+)?)|((0+(\.0*)?|\.0+)([eE]\+?\d+)?)|(0+\.\d*([eE]-\d+)?)|((1|1\.0*)([eE]-\d+)?)|(\d(\.\d*)?([eE]-[1-9]\d*)))\s+){3}(\+?((\.\d+([eE]-\d+)?)|((0+(\.0*)?|\.0+)([eE]\+?\d+)?)|(0+\.\d*([eE]-\d+)?)|((1|1\.0*)([eE]-\d+)?)|(\d(\.\d*)?([eE]-[1-9]\d*))))$(
# just a way to comment
# The ^$ anchors are there because xml always assumes them.
# They are required here for proper testing.
)*/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+?((\\.\\d+([eE]-\\d+)?)|((0+(\\.0*)?|\\.0+)([eE]\\+?\\d+)?)|(0+\\.\\d*([eE]-\\d+)?)|((1|1\\.0*)([eE]-\\d+)?)|(\\d(\\.\\d*)?([eE]-[1-9]\\d*)))\\s+){3}(\\+?((\\.\\d+([eE]-\\d+)?)|((0+(\\.0*)?|\\.0+)([eE]\\+?\\d+)?)|(0+\\.\\d*([eE]-\\d+)?)|((1|1\\.0*)([eE]-\\d+)?)|(\\d(\\.\\d*)?([eE]-[1-9]\\d*))))$(
# just a way to comment
# The ^$ anchors are there because xml always assumes them.
# They are required here for proper testing.
)*', 'm')
const str = `0.0e10 .0e+10 .0 0e-10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}