using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<myField>[^\s]+)\s*";
string input = @"T11345DDF ERROR
T11345SSDF Volume C
123455-25335535-55454545-5656566-45655-36565656-6656-488656 TPM
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}