import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<myField>[^\\s]+)\\s*";
final String string = "T11345DDF ERROR\n"
+ "T11345SSDF Volume C\n"
+ "123455-25335535-55454545-5656566-45655-36565656-6656-488656 TPM\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}