const regex = /^(?<myField>[^\s]+)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<myField>[^\\s]+)\\s*', 'gm')
const str = `T11345DDF ERROR
T11345SSDF Volume C
123455-25335535-55454545-5656566-45655-36565656-6656-488656 TPM
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}