#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!99\.0*[^0\n])(?=.*[1-9])\d{0,2}(?:\.\d{0,10})?$"
Local $sString = "Should only match numbers between 0.01 and 99.00" & @CRLF & _
"" & @CRLF & _
"Should Not Match" & @CRLF & _
"00" & @CRLF & _
"99.01" & @CRLF & _
"99.1" & @CRLF & _
"99.10" & @CRLF & _
"100" & @CRLF & _
"" & @CRLF & _
"Should Match" & @CRLF & _
"0.01" & @CRLF & _
"0.10" & @CRLF & _
"1.233" & @CRLF & _
"3.20" & @CRLF & _
"4.655" & @CRLF & _
"5.112" & @CRLF & _
"99.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")