use strict;
my $str = 'Should only match numbers between 0.01 and 99.00
Should Not Match
00
99.01
99.1
99.10
100
Should Match
0.01
0.10
1.233
3.20
4.655
5.112
99.00';
my $regex = qr/^(?!99\.0*[^0\n])(?=.*[1-9])\d{0,2}(?:\.\d{0,10})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}