re = /^(?!99\.0*[^0\n])(?=.*[1-9])\d{0,2}(?:\.\d{0,10})?$/m
str = 'Should only match numbers between 0.01 and 99.00
Should Not Match
00
99.01
99.1
99.10
100
Should Match
0.01
0.10
1.233
3.20
4.655
5.112
99.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end