import Foundation
let pattern = #"^(?!99\.0*[^0\n])(?=.*[1-9])\d{0,2}(?:\.\d{0,10})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Should only match numbers between 0.01 and 99.00
Should Not Match
00
99.01
99.1
99.10
100
Should Match
0.01
0.10
1.233
3.20
4.655
5.112
99.00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)