const regex = /^(?!99\.0*[^0\n])(?=.*[1-9])\d{0,2}(?:\.\d{0,10})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!99\\.0*[^0\\n])(?=.*[1-9])\\d{0,2}(?:\\.\\d{0,10})?$', 'gm')
const str = `Should only match numbers between 0.01 and 99.00
Should Not Match
00
99.01
99.1
99.10
100
Should Match
0.01
0.10
1.233
3.20
4.655
5.112
99.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}