package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\n ]*((<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|((") *.+ *("))|((') *.+ *('))|(\\" *.+ *\\")|(\\' *.+ *\\')))* *((\/)|(>([ \n]|.)*<\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)([\n ]*<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|((") *.+ *("))|((') *.+ *('))|(\\" *.+ *\\")|(\\' *.+ *\\')))* *((\/)|(>([ \n]|.)*<\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)*)[\n ]*$)`)
var str = `<div attr1="value"></div>
<!-- this is a HTML comment -->`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}