import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\n ]*((<((([a-zA-Z]+)( +(\\w|\\w+-+\\w*)+ *= *(( *(\\w|\\w+-+\\w*)+ *)|((\") *.+ *(\"))|((') *.+ *('))|(\\\\\" *.+ *\\\\\")|(\\\\' *.+ *\\\\')))* *((\\/)|(>([ \\n]|.)*<\\/[a-zA-Z]+)))|(!--([ \\n]|.)*--))>)([\\n ]*<((([a-zA-Z]+)( +(\\w|\\w+-+\\w*)+ *= *(( *(\\w|\\w+-+\\w*)+ *)|((\") *.+ *(\"))|((') *.+ *('))|(\\\\\" *.+ *\\\\\")|(\\\\' *.+ *\\\\')))* *((\\/)|(>([ \\n]|.)*<\\/[a-zA-Z]+)))|(!--([ \\n]|.)*--))>)*)[\\n ]*$)";
final String string = "<div attr1=\"value\"></div>\n"
+ "<!-- this is a HTML comment -->";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}