using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"smoke(s?)-(test|\d{1})-app-([0-9A-Fa-f\-]{36}|[0-9A-Fa-f\-]{16})";
string input = @"smoke-test-app-f47980d7-b3e5-49eb-99b6-d7413e16a0bc
SMOKES-2-APP-a9a8f59dd3c74046";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}