$re = '/smoke(s?)-(test|\d{1})-app-([0-9A-Fa-f\-]{36}|[0-9A-Fa-f\-]{16})/mi';
$str = 'smoke-test-app-f47980d7-b3e5-49eb-99b6-d7413e16a0bc
SMOKES-2-APP-a9a8f59dd3c74046';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);