import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "smoke(s?)-(test|\\d{1})-app-([0-9A-Fa-f\\-]{36}|[0-9A-Fa-f\\-]{16})";
final String string = "smoke-test-app-f47980d7-b3e5-49eb-99b6-d7413e16a0bc\n"
+ "SMOKES-2-APP-a9a8f59dd3c74046";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}