# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"smoke(s?)-(test|\d{1})-app-([0-9A-Fa-f\-]{36}|[0-9A-Fa-f\-]{16})"
test_str = ("smoke-test-app-f47980d7-b3e5-49eb-99b6-d7413e16a0bc\n"
"SMOKES-2-APP-a9a8f59dd3c74046")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.