const regex = /smoke(s?)-(test|\d{1})-app-([0-9A-Fa-f\-]{36}|[0-9A-Fa-f\-]{16})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('smoke(s?)-(test|\\d{1})-app-([0-9A-Fa-f\\-]{36}|[0-9A-Fa-f\\-]{16})', 'gmi')
const str = `smoke-test-app-f47980d7-b3e5-49eb-99b6-d7413e16a0bc
SMOKES-2-APP-a9a8f59dd3c74046`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}