using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[\d{2}:\d{2}-\d{2}:\d{2}])";
string input = @"[10:42-23:10]part1[11:30-13:20]part2[4][5]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}