re = /(\[\d{2}:\d{2}-\d{2}:\d{2}])/
str = '[10:42-23:10]part1[11:30-13:20]part2[4][5]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end