#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?ms)(?<node>node\d+).*?Attack database version:(?<Attack_database_version>\d+).*?Detector version\s*:(?<Detector_version>[^\n]+).*?Policy template version\s*:(?<Policy_template_version>\d+)"
Local $sString = "Feb 27 14:12:38" & @CRLF & _
"node0:" & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"Attack database version:3670(Thu Feb 22 14:12:38 2024 UTC)" & @CRLF & _
"Detector version :12.2.140230313" & @CRLF & _
"Policy template version :3535" & @CRLF & _
"" & @CRLF & _
"node1:" & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"Attack database version:3670(Thu Feb 22 14:12:38 2024 UTC)" & @CRLF & _
"Detector version :12.2.140230313" & @CRLF & _
"Policy template version :3535"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")