# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?ms)(?<node>node\d+).*?Attack database version:(?<Attack_database_version>\d+).*?Detector version\s*:(?<Detector_version>[^\n]+).*?Policy template version\s*:(?<Policy_template_version>\d+)"
test_str = ("Feb 27 14:12:38\n"
"node0:\n"
"--------------------------------------------------------------------------\n\n"
"Attack database version:3670(Thu Feb 22 14:12:38 2024 UTC)\n"
"Detector version :12.2.140230313\n"
"Policy template version :3535\n\n"
"node1:\n"
"--------------------------------------------------------------------------\n\n"
"Attack database version:3670(Thu Feb 22 14:12:38 2024 UTC)\n"
"Detector version :12.2.140230313\n"
"Policy template version :3535")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.