const regex = /(?ms)(?<node>node\d+).*?Attack database version:(?<Attack_database_version>\d+).*?Detector version\s*:(?<Detector_version>[^\n]+).*?Policy template version\s*:(?<Policy_template_version>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?ms)(?<node>node\\d+).*?Attack database version:(?<Attack_database_version>\\d+).*?Detector version\\s*:(?<Detector_version>[^\\n]+).*?Policy template version\\s*:(?<Policy_template_version>\\d+)', 'gm')
const str = `Feb 27 14:12:38
node0:
--------------------------------------------------------------------------
Attack database version:3670(Thu Feb 22 14:12:38 2024 UTC)
Detector version :12.2.140230313
Policy template version :3535
node1:
--------------------------------------------------------------------------
Attack database version:3670(Thu Feb 22 14:12:38 2024 UTC)
Detector version :12.2.140230313
Policy template version :3535`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}