import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)(?<node>node\\d+).*?Attack database version:(?<Attack_database_version>\\d+).*?Detector version\\s*:(?<Detector_version>[^\\n]+).*?Policy template version\\s*:(?<Policy_template_version>\\d+)";
final String string = "Feb 27 14:12:38\n"
+ "node0:\n"
+ "--------------------------------------------------------------------------\n\n"
+ "Attack database version:3670(Thu Feb 22 14:12:38 2024 UTC)\n"
+ "Detector version :12.2.140230313\n"
+ "Policy template version :3535\n\n"
+ "node1:\n"
+ "--------------------------------------------------------------------------\n\n"
+ "Attack database version:3670(Thu Feb 22 14:12:38 2024 UTC)\n"
+ "Detector version :12.2.140230313\n"
+ "Policy template version :3535";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}