$re = '/(?ms)(?<node>node\d+).*?Attack database version:(?<Attack_database_version>\d+).*?Detector version\s*:(?<Detector_version>[^\n]+).*?Policy template version\s*:(?<Policy_template_version>\d+)/m';
$str = 'Feb 27 14:12:38
node0:
--------------------------------------------------------------------------
Attack database version:3670(Thu Feb 22 14:12:38 2024 UTC)
Detector version :12.2.140230313
Policy template version :3535
node1:
--------------------------------------------------------------------------
Attack database version:3670(Thu Feb 22 14:12:38 2024 UTC)
Detector version :12.2.140230313
Policy template version :3535';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);