#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\(\s*)[abcd|\d](\s*\)*)$|\d$|\s+[abcd]$|[abcd]\)|\([a-z]+\)$|[\-,.\/]\s*[abcd]$|\(\d{1,}\)$"
Local $sString = "Nguyễn Đức Anhb" & @CRLF & _
"Nguyễn Đức Anh/b" & @CRLF & _
"Nguyễn Đức Anh (mb)" & @CRLF & _
"Nguyễn Đức Anh (hn)" & @CRLF & _
"Nguyễn Đức Anh (hsdb)" & @CRLF & _
"Nguyễn Đức Anh - b" & @CRLF & _
"Nguyễn Đức Anh.b" & @CRLF & _
"Nguyễn Đức Anh -b" & @CRLF & _
"Nguyễn Đức Anh-b" & @CRLF & _
"Nguyễn Đức a" & @CRLF & _
"Nguyễn Đức Anh b" & @CRLF & _
"Nguyễn Đức Anh (a)" & @CRLF & _
"Nguyễn Đức Anh (b)" & @CRLF & _
"Nguyễn Đức Anh (a" & @CRLF & _
"Nguyễn Đức Anh (b" & @CRLF & _
"Nguyễn Đức Anh (b" & @CRLF & _
"Nguyễn Đức Anha)" & @CRLF & _
"Nguyễn Đức Anh(b)" & @CRLF & _
"Nguyễn Đức Anh (a )" & @CRLF & _
"Nguyễn Đức Anh ( c)" & @CRLF & _
"Nguyễn Đức Anh1" & @CRLF & _
"Nguyễn Đức Anh2" & @CRLF & _
"Nguyễn Đức Anh 1" & @CRLF & _
"Nguyễn Đức Anh 2" & @CRLF & _
"Nguyễn Đức Anh (1)" & @CRLF & _
"Nguyễn Đức Anh (21)" & @CRLF & _
"Nguyễn Đức Anh " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")