package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\(\s*)[abcd|\d](\s*\)*)$|\d$|\s+[abcd]$|[abcd]\)|\([a-z]+\)$|[\-,.\/]\s*[abcd]$|\(\d{1,}\)$`)
var str = `Nguyễn Đức Anhb
Nguyễn Đức Anh/b
Nguyễn Đức Anh (mb)
Nguyễn Đức Anh (hn)
Nguyễn Đức Anh (hsdb)
Nguyễn Đức Anh - b
Nguyễn Đức Anh.b
Nguyễn Đức Anh -b
Nguyễn Đức Anh-b
Nguyễn Đức a
Nguyễn Đức Anh b
Nguyễn Đức Anh (a)
Nguyễn Đức Anh (b)
Nguyễn Đức Anh (a
Nguyễn Đức Anh (b
Nguyễn Đức Anh (b
Nguyễn Đức Anha)
Nguyễn Đức Anh(b)
Nguyễn Đức Anh (a )
Nguyễn Đức Anh ( c)
Nguyễn Đức Anh1
Nguyễn Đức Anh2
Nguyễn Đức Anh 1
Nguyễn Đức Anh 2
Nguyễn Đức Anh (1)
Nguyễn Đức Anh (21)
Nguyễn Đức Anh
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}