import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(\\s*)[abcd|\\d](\\s*\\)*)$|\\d$|\\s+[abcd]$|[abcd]\\)|\\([a-z]+\\)$|[\\-,.\\/]\\s*[abcd]$|\\(\\d{1,}\\)$";
final String string = "Nguyễn Đức Anhb\n"
+ "Nguyễn Đức Anh/b\n"
+ "Nguyễn Đức Anh (mb)\n"
+ "Nguyễn Đức Anh (hn)\n"
+ "Nguyễn Đức Anh (hsdb)\n"
+ "Nguyễn Đức Anh - b\n"
+ "Nguyễn Đức Anh.b\n"
+ "Nguyễn Đức Anh -b\n"
+ "Nguyễn Đức Anh-b\n"
+ "Nguyễn Đức a\n"
+ "Nguyễn Đức Anh b\n"
+ "Nguyễn Đức Anh (a)\n"
+ "Nguyễn Đức Anh (b)\n"
+ "Nguyễn Đức Anh (a\n"
+ "Nguyễn Đức Anh (b\n"
+ "Nguyễn Đức Anh (b\n"
+ "Nguyễn Đức Anha)\n"
+ "Nguyễn Đức Anh(b)\n"
+ "Nguyễn Đức Anh (a )\n"
+ "Nguyễn Đức Anh ( c)\n"
+ "Nguyễn Đức Anh1\n"
+ "Nguyễn Đức Anh2\n"
+ "Nguyễn Đức Anh 1\n"
+ "Nguyễn Đức Anh 2\n"
+ "Nguyễn Đức Anh (1)\n"
+ "Nguyễn Đức Anh (21)\n"
+ "Nguyễn Đức Anh \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}