import Foundation
let pattern = #"(\(\s*)[abcd|\d](\s*\)*)$|\d$|\s+[abcd]$|[abcd]\)|\([a-z]+\)$|[\-,.\/]\s*[abcd]$|\(\d{1,}\)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Nguyễn Đức Anhb
Nguyễn Đức Anh/b
Nguyễn Đức Anh (mb)
Nguyễn Đức Anh (hn)
Nguyễn Đức Anh (hsdb)
Nguyễn Đức Anh - b
Nguyễn Đức Anh.b
Nguyễn Đức Anh -b
Nguyễn Đức Anh-b
Nguyễn Đức a
Nguyễn Đức Anh b
Nguyễn Đức Anh (a)
Nguyễn Đức Anh (b)
Nguyễn Đức Anh (a
Nguyễn Đức Anh (b
Nguyễn Đức Anh (b
Nguyễn Đức Anha)
Nguyễn Đức Anh(b)
Nguyễn Đức Anh (a )
Nguyễn Đức Anh ( c)
Nguyễn Đức Anh1
Nguyễn Đức Anh2
Nguyễn Đức Anh 1
Nguyễn Đức Anh 2
Nguyễn Đức Anh (1)
Nguyễn Đức Anh (21)
Nguyễn Đức Anh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)