#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b[0-9]+\s*k\b"
Local $sString = "1) 150 k" & @CRLF & _
"2) 150 kilobyte" & @CRLF & _
"3) 150 ka" & @CRLF & _
"4) 150 k2" & @CRLF & _
"5) 150 k)" & @CRLF & _
"6) 150 k." & @CRLF & _
"150 k <- beginning of line" & @CRLF & _
"... works with other characters (150 k)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")