re = /\b[0-9]+\s*k\b/
str = '1) 150 k
2) 150 kilobyte
3) 150 ka
4) 150 k2
5) 150 k)
6) 150 k.
150 k <- beginning of line
... works with other characters (150 k)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end