import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[0-9]+\\s*k\\b";
final String string = "1) 150 k\n"
+ "2) 150 kilobyte\n"
+ "3) 150 ka\n"
+ "4) 150 k2\n"
+ "5) 150 k)\n"
+ "6) 150 k.\n"
+ "150 k <- beginning of line\n"
+ "... works with other characters (150 k)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}