$re = '`\b[0-9]+\s*k\b`';
$str = '1) 150 k
2) 150 kilobyte
3) 150 ka
4) 150 k2
5) 150 k)
6) 150 k.
150 k <- beginning of line
... works with other characters (150 k)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);