const regex = new RegExp('\\s(?!money$).*', 'g')
const str = `Hello monet`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);