import Foundation
let pattern = #"\s(?!money$).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hello monet"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)