use strict;
my $str = 'Hello monet';
my $regex = qr/\s(?!money$).*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";