$re = '/\s(?!money$).*/';
$str = 'Hello monet';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;