# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[a-zA-Z]+:\/\/[a-zA-Z]+\.[a-zA-Z]+\/[a-zA-Z]+([+-]?(?=\.\d|\d)(?:\d+)?(?:\.?\d*))(?:[eE]([+-]?\d+))?_[0-9]+//gm;t' <<< "https://vk.com/wall-170006123_92120"